VMWare Server no Ubuntu 10.10

domingo, 18 de setembro de 2011

Olá.

Algum tempo atrás, iniciei uma homologação de softwares no Ubuntu 10.04 LTS. E praticamente tudo funcionou. Porém, acabei não postando os relatos.

Como fiz um upgrade recente, acabei formatando e reinstalando tudo. Tentei, conforme comentado dias atrás, usar a versão 64, sem muito sucesso.
Resolvi instalar a 32 mesmo, do 10.04. Mas infelizmente, não consegui instalar o VMWare Server. Tentei por um bom tempo e nada. Mesmo usando praticamente o mesmo que fiz na estação de homologação.
Pra não perder tempo, instalei o 10.10 e pra minha surpresa, instalou perfeitamente.

Irei aqui, relatar o que fiz:

Os ingredientes necessários são o próprio VMWare Server (baixado do próprio site da VMWare) e um patch do RaduCotescu (baixado no site dele). O lance desse patch, é que existem 2 versões (1.50 e 1.60). A princípio, tentei com a mais atual, sem sucesso. Quando testei a 1.50, funcionou na hora.

A sacada aqui, é manter o arquivo compactado do VMWare no mesmo diretório dos arquivos do patch (que você irá descompactar).
Rodando o patch, ele mesmo irá baixar algumas dependências e descompactar o arquivo do VMWare. Se tudo correr bem, ele já irá iniciar a instalação (que é a parte que você interage).
Ao final, basta ir no browser, acessando a URL: http://localhost:8222
Lembre-se de logar como root. Caso não tenha atribuído uma senha pro root, faça isso com: sudo chpasswd root
Até aí, tudo bem. Porém, mesmo conseguindo gerenciar o VMWare via browser, pelo Firefox, por exemplo, não é possível abrir um console VM. Dá um erro no próprio Firefox.
A dica então, é chamar um "console de VM's" diretamente pelo plugin.
Pra isso, basta chamar o arquivo:

/home/SEU_USUÁRIO/.mozilla/firefox/PERFIL_DO_FIREFOX/extensions/VMwareVMRC@vmware.com/plugins/vmware-vmrc

Porém, aqui pode ainda dar um problema. Caso tenha atualizado o Firefox, antes de tentar acessar o VMWare alguma vez, o plugin não será instalado. Ou você baixa o plugin manualmente ou simplesmente atualize o Firefox (pro 6.0 por exemplo), somente após ter feito algum acesso ao VMWare via web. Dessa forma, o plugin será instalado (mesmo não rodando diretamente). Aí sim, você acesso o caminho acima, para gerenciar e utilizar as VM's.

Bom, pra finalizar, caso faça alguma atualização de kernel, será necessário chamar o: vmware-config.pl
No meu caso, fiz uma pra reconhecer mais de 3GB de memória (limitação do 32bits). E mesmo chamando o config.pl, não deu certo. Dava um erro de compilador e tal. Resolvi instalando o VMWare novamente, pelo install.

Por aqui, deu certo. =)

KXMame no Ubuntu 10.10

domingo, 11 de setembro de 2011

Olá.

Pra quem estiver tendo problemas de não encontrar o diretório do xmame ou similar no Ubuntu 10.10, para o KXMame, vai uma dica:

Desinstale o xmame-sdl.

Instale a partir do repositório: http://ftp.debian.org/debian/pool/non-free/x/xmame/

Primeiro o:

xmame-sdl_0.106-2.1_i386.deb 21-Jun-2.008 21:02 9.4M

Em seguida, atualize para o:

xmame-sdl_0.106-3.2_i386.deb 06-Dec-2009 11:55 9.4M

Se na hora de desinstalar, pedir pra remover o KXMame, remova sem problema. Após os 2 passos acima, instale ele novamente.
Fiz exatamente isso e funcionou. =)

Créditos para: http://www.ubuntu-es.org/node/142974

Ainda sobre ele, um adendo; tentei rodar em fullscreen numa resolução de 1680x1050 e dava um crash bem estranho. Só funcionou, diminuindo pra 1024x768. Fica a dica.

[]s

Ubuntu 64bits

sexta-feira, 9 de setembro de 2011

Olá.

Fiz um upgrade recente e decidi instalar uma versão 64 bits do Ubuntu.

Em termos de desempenho, um espetáculo (mas talvez mais pela diferença do poderia do i5+DDR3 contra meu cansado Dual Core). Porque pelo que vi em comparativos, a diferença de desempenho é de poucos % ou frames aqui e alí, dentro do que foi medido.
O problema foi (e é o que todo mundo diz), a compatibilidade com aplicações mais específicas.

Meu divisor de águas foi o VMWare. É por ele que estudo, então ele é fundamental. E não, não pretendo investir meu tempo agora em outros softwares de virtualização. Brinquei com outros no passado e o que me agradou e uso na produção 24/7 é o VMWare.
Baixei a versão 64 dele e tentei instalar. Diversos erros. Perdi um tempo razoável tentando resolver, mas sem sucesso.
O Adobe Air também não instalou. Mas esse, eu até abriria mão, já que é apenas pra usar o TweetDeck.

Enfim... hoje reinstalo o 32 e serei feliz (seguindo a dica para reconhecer mais de 4GB, claro). =P